Python 集成开发环境(IDE) Eric 5.1.5 发布

webphp 10年前
     <p>Eric5 是一个集成了项目管理功能的 Python 集成开发环境。提供无限制数量的编辑器、集成的 Python Shell、集成调试器、集成对包括 Subversion 和 Mercurial 版本控制系统的支持。集成单元测试等等。可通过插件系统来进行功能扩展,与 Eric4 相比,Eric5 是基于 Python 3 的变种。</p>    <p><img title="Python 集成开发环境(IDE) Eric 5.1.5 发布" border="0" alt="Python 集成开发环境(IDE) Eric 5.1.5 发布" src="https://simg.open-open.com/show/23ea342f6d2144c60d22ca595289f45b.jpg" width="600" height="388" /><br /> <br /> Eric 5.1.5 发布,该版本主要是bug修复工作。<br /> 项目地址:<a href="/misc/goto?guid=4958189003258216010" target="_blank">http://eric-ide.python-projects.org/index.html</a><br /> </p>    <p>下载:</p>    <h3>eric4 IDE</h3>    <ul>     <li><a href="/misc/goto?guid=4958189003999484065">Download eric4</a></li>     <li><a href="/misc/goto?guid=4958189004735677296">Latest eric4 snapshots</a></li>    </ul>    <h3>eric5 IDE</h3>    <ul>     <li><a href="/misc/goto?guid=4958189005476130224">Download eric5</a></li>     <li><a href="/misc/goto?guid=4958189006214509899">Latest eric5 snapshots</a></li>    </ul>    <h3>eric4 plugins</h3>    <ul>     <li><a href="/misc/goto?guid=4958189006941792113">Download stable eric4 plugins</a></li>     <li><a href="/misc/goto?guid=4958189007686756840">Latest eric4 plugins snapshots</a></li>    </ul>    <h3>eric5 plugins</h3>    <ul>     <li><a href="/misc/goto?guid=4958189008425864447">Download stable eric5 plugins</a></li>     <li><a href="/misc/goto?guid=4958189009152555821">Latest eric5 plugins snapshots</a></li>    </ul>    <h4>Prerequisites</h4>    <p>To be able to run eric4 you should have the following installed:</p>    <ul>     <li><a href="/misc/goto?guid=4958189009883329314">Python 2.5.0 or better</a></li>     <li><a href="/misc/goto?guid=4958189010622192866">Qt 4.5.0 or better (from Nokia)</a></li>     <li><a href="/misc/goto?guid=4958189011350772140">PyQt 4.4.0 or better (from Riverbank)</a></li>     <li><a href="/misc/goto?guid=4958189012084705405">QScintilla 2.2.0 or better (from Riverbank)</a></li>    </ul>    <p>To be able to run eric5 you should have the following installed:</p>    <ul>     <li><a href="/misc/goto?guid=4958189009883329314">Python 3.1.0 or better</a></li>     <li><a href="/misc/goto?guid=4958189010622192866">Qt 4.5.0 or better (from Nokia)</a></li>     <li><a href="/misc/goto?guid=4958189011350772140">PyQt 4.7.0 or better (from Riverbank)</a></li>     <li><a href="/misc/goto?guid=4958189012084705405">QScintilla 2.4.0 or better (from Riverbank)</a></li>    </ul>    <p>Optionally you may download and install the following python modules to make full use of the IDE and the offered plugins:</p>    <ul>     <li><a href="/misc/goto?guid=4958184358267976870">Subversion</a></li>     <li><a href="/misc/goto?guid=4958189016189777870">PySvn</a> (Python interface to Subversion)</li>     <li><a href="/misc/goto?guid=4958189016929014603">rope refactoring library</a></li>     <li><a href="/misc/goto?guid=4958189017662262003">PyLint</a></li>     <li><a href="/misc/goto?guid=4958189018423122309">CX_Freeze</a></li>     <li><a href="/misc/goto?guid=4958189019160048907">PyEnchant</a> (spell checking)</li>    </ul>    <p></p>