Ruby on Rails:3.2 RC1发布,4.0将会放弃Ruby 1.8.7

openkk 11年前
     <p>Ruby on Rails组宣布Rails 3.2的首个发布候选版,正好赶上圣诞节。3.2之后,Rails的下一个主要发布将会是4.0。</p>    <p>Rails 3.2引入了一些新特性和许多小改进。最显著的新特性是更快的开发模式,它将会影响所有用户。根据<a href="/misc/goto?guid=4958322709515826482">详细的更改日志</a>,加快开发速度的方式是仅在依赖的文件发生更改时才会重新加载类,而现在的做法是Rails会在每次请求时重新加载类。如果你想要Rails之前版本的效果,你可以试一下<a href="/misc/goto?guid=4958322710309074227">ActiveReload插件</a>。</p>    <p>如果你在处理因数据库查询的低效而导致的性能问题,新的<a href="/misc/goto?guid=4958322711103223819">explain特性</a>或许可以帮你找到问题。Arel现在提供了一个<tt>explain</tt>方法,在生成的查询上运行EXPLAIN并显示结果。它可以和sqlite3,mysql2和postgresql的适配器一起工作。当Rails发现一个很慢的查询时(默认是0.5秒),它就会自动运行explain,并向你显示结果。</p>    <p>其它新特性包括一个简单的Active Record键/值存储扩展和一个允许你向日志添加自定义标记的日志记录程序。若想了解所有更改的完整概览,可以查看<a href="/misc/goto?guid=4958322709515826482">详细的更改日志</a>。</p>    <p>3.2发布之后将会集中精力开发4.0版本,目前计划于2012年夏天发布。DHH解释了他们为何跳到下一个主要版本号:</p>    <blockquote>     关于我们将在Rails 4.0里包含什么特性目前没有更多的细节,但采用主要版本号的主要目的是放弃Ruby 1.8.7的支持。和Rails 3.0不同的是,我们希望这个转变更加平滑。    </blockquote>    <p>放弃1.8.7一开始可能很困难,但Ruby组本身也在<a href="/misc/goto?guid=4958322712627359633">从1.8转移出去</a>:“我们会像往常一样继续为1.8.7提供常规维护,直到2012年六月为止。…… 从那以后,我们将会停止修正错误,但我们仍然提供安全错误的修正,直到2013年六月为止。”除非其他人接手并继续维护它(像<a href="/misc/goto?guid=4958322713411285418">Engine Yard处理</a>Ruby 1.8.6那样),否则是时候彻底转到Ruby 1.9或某个替代实现。</p>    <p><b>查看英文原文:</b><a href="/misc/goto?guid=4958322714221512629">Ruby on Rails: 3.2 RC1 Released, 4.0 Will Drop Ruby 1.8.7</a><br /> 来自:<a href="/misc/goto?guid=4958322715005601268" target="_blank">http://www.infoq.com/cn/news/2011/12/rails-32-40</a></p>