Meteor 1.2:支持ECMAScript 2015、Angular JS和React

jopen 6年前
 

Meteor 1.2 正式发布 ,官方宣布将ECMAScript 2015作为Meteor平台所使用的JavaScript语言版本,这一版同时也支持了Angular和React。

Meteor的创始人Matt DeBergalis在谈到他们这次采用ECMAScript 2015作为官方JavaScript语言版本时说到:

我们认为每一个人都应该使用ES2015来编写app,这会驱使许多习惯于其它语言的开发者来使用最新版的JavaScript。

因此我们火力全开: Meteor的教程 完全使用纯净的ES2015写成,Meteor的核心部分也正逐步替换为ES2015。感谢新的语言标准中内建支持了类、块级变量作用域、箭头函数、模板字符串以及 许多其它改进 ,我们发现ES2015让编写出来的代码突然变得简洁易读。

DeBergalls接着说:“现在,每个新的Meteor项目中的每个JS文件默认都使用ES2015,最重要的是它100%向后兼容”。

Meteor的即时模板引擎名为Blase,在1.2版本中增添了对 Angular JSReact 的支持。DeBergalis认为“React集成是一组基于现有成果开发的由Meteor开发组维护的包”,他们同时也在Meteor的技术栈中集成了Angular包。

Meteor 1.2还提供一个新的构建管道,用Cordova来促进移动开发,并且用p ermessage-deflate 实现websocket压缩的功能。

广大社区热情地接受了Meteor最近的更新。在 Hacker News 上,用户thesunny

Meteor+React组合能够非常出色地完成它们的使命。

我极力推荐大家去了解一个Meteor、React和Webpack三剑合一的新项目: https://github.com/thereactivestack/meteor-webpack-react-kickstart

在Meteor中,我唯独不喜欢开发大型项目时重载/刷新的速度,最糟糕得时候大约在10秒左右,这是用Node做大型项目时的一个通病。

如果改用Meteor+React+Webpack组合,只有当模块改变时才会热加载。由于此时客户端代码比服务端代码丰富得多,所以不再需要花费10秒钟进行重载,只需一眨眼的功夫就可以完成刷新。

社区中还有其它一些声音,在 RedditHacker News 上,一些人强烈要求支持SQL,但对Meteor依旧保持了一个良好的评价。

Reddit上有这样一个题为《 Meteor just released version 1.2 with ECMA 2015 and official support for React & Angular 》的讨论,CSS9的全栈工程师 clessg 认为 :“Meteor和React是一个优秀的组合,我迫不及待地想看到Galaxy和SQL被支持。Meteor是一项伟大的工程,感谢对社区如此有责任心。”

欲了解更多有关Meteor 1.2的新闻和重大改变,请阅读官方的 发布说明

查看英文原文:Meteor 1.2: ECMAScript 2015 and support for AngularJS, React