Spark 1.5将不再支持Java 6

bgn4 7年前

 在几年前,Oracle宣布不再维护Java 6的更新(看这里http://www.computerworld.com/article/2494112/application- security/oracle-to-stop-patching-java-6-in-february-2013.html),那么Java 6发现的新bug Oracle公司也就不再会去修改,这对用户来说就是不好的消息。

在前几天发布的Hadoop 2.7.0 (《Hadoop 2.7.0发布:不适用于生产和不支持JDK1.6》)中的一个重要的更新就是也不再支持JDK1.6。

近日,Spark 社区也在讨论是否应该终止支持Java 6,经过这几天的讨论,社区决定从Spark 1.5开始,不再支持Java 1.6!
1、Spark 1.4.x(~ Jun 2015)会在Java 6,7,8上面工作;
2、Spark 1.5+ (~ Sep 2015)只能在Java 7,8上面工作,不再支持Java 6!

原文如下:

Hi all,

We will drop support for Java 6 starting Spark 1.5, tentative scheduled to
be released in Sep 2015. Spark 1.4, scheduled to be released in June 2015,
will be the last minor release that supports Java 6. That is to say:

Spark 1.4.x (~ Jun 2015): will work with Java 6, 7, 8.

Spark 1.5+ (~ Sep 2015): will NOT work with Java 6, but work with Java 7, 8.

PS: Oracle ended Java 6 updates in Feb 2013.

来自:http://www.iteblog.com/archives/1344