jQuery 2.0 beta发布,不再支持IE6/7/8

jopen 9年前

        jQuery 开发团队今天发布了 jQuery 1.9 正式版本和 jQuery 2.0 beta 版本。 

jQuery 2.0 beta发布,不再支持IE6/7/8

        在 jQuery 2.0 中,将移除对老 IE 版本(IE 6/7/8)的支持,如果开发者比较在意老版本 IE 用户,只能使用 jQuery 1.9 及之前的版本了。 

        关于 jQuery 1.9 和 jQuery 2.0 的版本区别如下: 

  • jQuery 1.9 和 2.0 有相同的 API。一些弃用的特性(如$.browser)在这两个版本中都已经移除。见 jQuery 1.9 升级指南
  • jQuery 1.9 可以运行在老版本 IE(IE 6/7/8)上,这和之前版本一样。与 jQuery 1.8 相比,该版本的 API 更简洁、更轻量、更现代。
  • jQuery 2.0 将无法运行在老版本 IE 上,由于减少了一些代码,使得该版本比 jQuery 1.9 更小且更快。

        jQuery 开发团队称,未来将同时支持 jQuery 1.9 和 2.0 两个版本,你可以根据自己的需要来选择。 

        jQuery 开发团队还发布了 jQuery 迁移插件1. 0 正式版,帮助检测新版本中已弃用和删除的功能,并可以在必要时恢复这些功能。 

        详细信息:jQuery Blog 

        下载地址: 

来自: www.iteye.com