Tomcat 全系报请求漏洞 CVE-2014-0227

jopen 7年前

CVE-2014-0227 Request Smuggling

危害程度:重要!

影响的版本包括:
- - Apache Tomcat 8.0.0-RC1 to 8.0.8
- - Apache Tomcat 7.0.0 to 7.0.54
- - Apache Tomcat 6.0.0 to 6.0.41

漏洞描述:

chucked 请求包含一个受损的 chunk 可能导致 Tomcat 读取部分请求的 body 做为一个新请求。

解决办法:
- - Upgrade to Apache Tomcat 8.0.9 or later
- - Upgrade to Apache Tomcat 7.0.55 or later
- - Upgrade to Apache Tomcat 6.0.43 or later (6.0.42 contains the fix but was not released)

官方消息:
http://mail-archives.apache.org/mod_mbox/www-announce/201502.mbox/%3C54D87A0F.7010400@apache.org%3E

来自:http://www.oschina.net/news/59546/tomcat-cve-2014-0227