CocoaPods 0.36正式发布,实现Swift和iOS 8动态框架支持

jopen 6年前

CocoaPods 0.36正式发布,实现Swift和iOS 8动态框架支持

经过数个月的努力和轮番测试,CocoaPods 核心团队成员 Marius Rackwitz 于近日在 CocoaPods 官方博客上宣布正式发布 CocoaPods 0.36,该版本最大的改动便是为 iOS 8 平台引入了动态框架,并增加了对于使用 Swift 语言所编写的库的支持,此举将影响到包括 CocoaPods/Xcodeproj 在内的所有 CocoaPods gems。

动态框架通常只存在于 OS X 之上,其优势在于对多平台代码更好的封装,由于缺乏对 iOS 平台的支持一直饱受 iOS 开发者诟病,而从 iOS 8 开始,CocoaPods 实现了对于第三方动态框架的支持。

除却实现对于动态框架的支持之外,CocoaPods 0.36 还实现了对于 AlamoFire、SwiftyJSON 等库的支持,而此前只能手工添加到项目中或是通过 git submodule 来管理,如果 pod 包含了 Swift 源码,更无法整合依赖。

现在,开发者可以将 CocoaPods 进行更新,想要了解更多关于 CocoaPods 0.36 的信息,可查看 CocoaPods Changelog

CocoaPods是什么?

当你开发iOS应用时,会经常使用到很多第三方开源类库,比如JSONKit,AFNetWorking等等。可能某个类库又用到其他类库,所以要 使用它,必须得另外下载其他类库,而其他类库又用到其他类库,“子子孙孙无穷尽也”,这也许是比较特殊的情况。总之小编的意思就是,手动一个个去下载所需 类库十分麻烦。另外一种常见情况是,你项目中用到的类库有更新,你必须得重新下载新版本,重新加入到项目中,十分麻烦。如果能有什么工具能解决这些恼人的 问题,那将“善莫大焉”。所以,你需要 CocoaPods。

CocoaPods应该是iOS最常用最有名的类库管理工具了,上述两个烦人的问题,通过cocoaPods,只需要一行命令就可以完全解决,当然 前提是你必须正确设置它。重要的是,绝大部分有名的开源类库,都支持CocoaPods。所以,作为iOS程序员的我们,掌握CocoaPods的使用是 必不可少的基本技能了。

来自: CSDN