linux下安装部署rabbitmq

jopen 5年前

MQ全称为Message Queue, 消息队列(MQ)是一种应用程序对应用程序的通信方法。应用程序通过读写出入队列的消息(针对应用程序的数据)来通信,而无需专用连接来链接它们。消 息传递指的是程序之间通过在消息中发送数据进行通信,而不是通过直接调用彼此来通信,直接调用通常是用于诸如远程过程调用的技术。排队指的是应用程序通过 队列来通信。队列的使用除去了接收和发送应用程序同时执行的要求。其中较为成熟的MQ产品有IBM WEBSPHERE MQ。
       RabbitMQ是一个在AMQP基础上完整的,可复用的企业消息系统。他遵循Mozilla Public License开源协议 。那么如何安装部署rabbitmq呢?
       
安装Erlang

1、下载推荐的安装包

http://www.rabbitmq.com/releases/erlang/

2、安装

1

rpm -ivh erlang-17.4-1.el6.x86_64.rpm

可能的报错

error: Failed dependencies:

        libodbc.so.2()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_baseu-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_baseu-2.8.so.0(WXU_2.8)(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_baseu_xml-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_adv-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_aui-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_core-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_gl-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_gl-2.8.so.0(WXU_2.8)(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_html-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_stc-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_stc-2.8.so.0(WXU_2.8)(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_xrc-2.8.so.0()(64bit) is needed by esl-erlang-18.2-1.x86_64

        libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) is needed by esl-erlang-18.2-1.x86_64


安装依赖包

1

yum install unixODBC unixODBC-devel wxBase wxGTK SDL wxGTK-gl

安装RabbitMQ Server

1

2

rpm --import https://www.rabbitmq.com/rabbitmq-signing-key-public.asc

yum install rabbitmq-server-3.5.7-1.noarch.rpm

启动

修改host

1

127.0.0.1 hostname

启动

1

service rabbitmq-server start

日志目录

/var/log/rabbitmq
安装完成。

如果想深入体验LINUX系统的新手,也可以先下载一个方德Linux软件中心试用一下。

免费下载地址:http://www.nfs-cloud.cn:81/appCenter/open/softcenter