解决eclipse中svn插件的【Subversion Native Library Not Available】

11年前
1、错误环境:错误出现在ubuntu系统中eclipse中。  2、影响:       (1)eclipse启动的时候,老是弹出【"Subversion native library not available"】,          每次我都不予理会,直接【cancel】这个错误。       (2) 痛心的事情在上述【cancel】之后发生,每次提交项目到版本控制时,eclipse坚决罢工,          总要Kill掉eclipse进程。甚是麻烦

3、解决方案:        (1)安装libsvn-java,   sudo apt-get install libsvn-java          (2)查找安装的依赖库位置。dpkg -L libsvn-java          (3)复制如下三个文件到$JAVA_HOME/jre/lib/i386中(32位系统,64位系统你懂得)          /usr/lib/jni/libsvnjavahl-1.so.0.0.0         /usr/lib/jni/libsvnjavahl-1.so        /usr/lib/jni/libsvnjavahl-1.so.0      具体操作: sudo cp /usr/lib/jni/libsvnjavahl-1* $JAVA_HOME/jre/lib/i386    4、重启eclipse问题解决    5、本来想截图一起发的,但是我不知道ubuntu的截图工具。下次应该会补上的。       如果有推荐留言我啊,不吝赐教,先谢谢了!


6、联系方式:MSN:leyxan@live.cn