Unity推出测试版支持ARCore内容开发

摘要:ARCore 目前可支持搭载 Android 7.0 Nougat 及以上版本系统的手机,如 Google Pixel、Pixel XL 及三星 Galaxy S8,需使用 Unity 2017.2b9 及以上版本,且 Android API SDK 版本在 v24 及以上。

Unity推出测试版支持ARCore内容开发

日前,Unity 宣布推出支持 ARCore 的测试版 Unity 2017.2b9。

ARCore 目前可支持搭载 Android 7.0 Nougat 及以上版本系统的手机,如 Google Pixel、Pixel XL 及三星 Galaxy S8,需使用 Unity 2017.2b9 及以上版本,且 Android API SDK 版本在 v24 及以上。

Unity 在官方微博中给出了详细的设置过程:

  • 下载并导入 ARCore SDK for Unity 插件到 Unity 项目;

  • 在目标设备上安装 Google ARCore 服务;

  • 在 Player Settings(Edit > Project Settings > Player)的 Android 标签下,勾选 XR Settings 下的 Tango Supported;

Unity推出测试版支持ARCore内容开发

在 Other Settings 下,确保取消勾选 Multithreaded Rendering,并将 Minimum API Level 设为 24:

Unity推出测试版支持ARCore内容开发

以上步骤设置完毕后,可以打开 Assets > GoogleARCore > HelloARExample > Scenes 下的 HelloAR 示例场景,将该场景加入构建列表,然后连接设备构建后运行,可以看到设备移动时,应用会自动检测平面并绘制点阵网格,点击网格即可在上方放置一个 Android 机器人。

Unity推出测试版支持ARCore内容开发

来自: 雷锋网

扩展阅读

Daydream Labs用ARCore做了什么?
谷歌的野心:让1亿部Android手机具有AR功能
独立开发者:复盘Unity手游[HyperBowl]
Unity5 引擎对游戏开发者意味着什么?
Unity 5.6推出 改进图形性能以及支持Vulkan API

为您推荐

50个值得收藏的实用CSS代码片段
10个新鲜的JavaScript/ jQuery插件,你一定要看看
Apache PDFBox 2.0.0 RC1 发布
Java处理PDF文件的类库,PDFBox 2.0.0 RC2 发布
5个实用的CSS代码开发片段

更多

Unity
ARCore
IT业界