imagej教程

niezheng 贡献于2016-11-28

作者 yang  创建于2011-01-20 12:45:00   修改者yang  修改于2011-01-20 12:45:00字数28702

文档摘要:ImageJ是一个公共领域的Java图像处理程序由美国国立卫生研究院的Macintosh形象的启发。它运行在 任何一个Java 1.1或更高版本的虚拟机电脑,无论是作为一个applet或网上下载的应用程序作为一个。
关键词:

关于本手册 - 请先阅读 ImageJ是一个公共领域的Java图像处理程序由美国国立卫生研究院的Macintosh形象的启发。它运行在 任何一个Java 1.1或更高版本的虚拟机电脑,无论是作为一个applet或网上下载的应用程序作为一个。 笔者,韦恩Rasband(wayne@codon.nih.gov),是在研究科,国立 心理健康,贝塞斯达,马里兰州,美国。 约ImageJ信息的最佳来源,可以发现在ImageJ网页(http://rsb.info.nih.gov/ij/)和 通过订阅ImageJ邮件列表(在主页上的细节)。本手册的目的是要介绍给 ImageJ光学显微镜 - 一个ImageJ的剧目一小部分。 ImageJ的一种方式,一个“插件”现在越来越多的补充本地大量功能(可选 需要额外安装)。的核心职能进行了详细的描述在ImageJ网站(按照 单证链接)。一个插件是一个文件(名为*.类),需要在“插件”子文件夹 ImageJ文件夹,否则ImageJ不会加载它。 在本手册中,本机的功能是指在斜体,黑白文本,由插件斜体,深蓝色 文本。 ImageJ功能都可以通过键盘快捷键访问,或“热键”。一些热键是硬到有线 ImageJ,而另一些用户定义的。与大多数其他Windows应用程序,键盘快捷方式不 要求“控制”键被按下(在Microsoft Word中,热键“复制”,例如,是按Ctrl + C)后,在 ImageJ,这就是“C”的。除非你已经安装了从赖特细胞成像设备网站(手册ImageJ 和软件的链接),插件本手册中提到的和定制的键盘快捷方式或多或少( “热键”)可能无法工作。 这也仅仅是被插件收集整理和我组织,他们都已经获得 摆脱ImageJ网站或其他地方上网。这项工作的信贷应该去 作者的插件(见附件)。请确保他们得到适当的承认,在任何 出版,他们的工作便利。我试图包括适当引用或联系方式 每位作者。让我知道任何遗漏,我会立即改正。 如果你是一个插件作者,你是不是你的插件的方式描述或包含或快乐 引,请让我知道。我会在必要时更新此手册。 本手册的目的是介绍性的概述,让您建立和运行,因此,并不详尽。 我开始工作,而在本手册Babraham学院,剑桥,英国(地址如下)就业。我 认为现在是一个“进展中的工作”。请发送任何意见: 托尼柯林斯博士 设施经理 赖特细胞成像设备 多伦多西方研究所 管委会13-407 399 Bathurst街 多伦多,开,M5T 2S8 电子邮箱:tonyc@uhnres.utoronto.ca 网址:www.uhnresearch.ca / wcif 目录 1安装ImageJ ............................................... .................................................. ........................... 1 1.1视窗................................................ .................................................. ................................................一 1.1.1安装程序文件............................................ .................................................. .............................................一 1.1.2更新核心方案............................................ .................................................. ..........................................一 1.1.3设置内存分配............................................ .................................................. ........................................一 1.2 Mac和Linux .............................................. .................................................. .........................................一 1.3 OS2的................................................ .................................................. .................................................. .......一 1.4 QuickTime的功能............................................... .................................................. .........................一 1.5升级................................................ .................................................. ..............................................一 1.5.1 ImageJ核心方案............................................ .................................................. ..........................................一 1.5.2插件.............................................. .................................................. .................................................. ............ 2 1.6 Java运行环境.............................................. .................................................. ..................... 2 1.6.1关于.............................................. .................................................. .................................................. .............. 2 1.6.2 JRE的版本比较............................................ .................................................. ..................................... 2 1.6.3安装的JRE ............................................ .................................................. ............................................... 2 1.6.4编译ImageJ插件一个新的JRE ........................................ .................................................. ...............三 2导入图像文件.............................................. .................................................. .................... 4 2.1导入蔡司LSM的文件............................................. .................................................. ......................... 4 2.2导入诺伦SGI的文件............................................. .................................................. ........................... 4 2.3导入Biorad PIC文件............................................. .................................................. ........................ 4 2.4从文件夹中导入多个文件............................................ .................................................. .......... 4 2.5导入多从文件夹中..........................................原始序列................................................ 5 2.6导入AVI和MOV文件............................................ .................................................. ..................... 5 2.7其他进口功能.............................................. .................................................. ............................ 5 3保存和导出文件............................................. .................................................. ............ 6 4强与时间分析............................................. .................................................. .............. 7 4.1亮度和对比度.............................................. .................................................. ......................... 7 从单一的投资回报率4.2入门强度值........................................... .................................................. .. 7 4.3强度随时间的动态分析............................................ .................................................. .......... 7 4.4如何从多个投资回报强度值........................................... ............................................... 8 4.5获取时间戳数据.............................................. .................................................. ....................... 9 4.5.1蔡司LSM的............................................. .................................................. .................................................. ........ 9 4.5.2诺伦.............................................. .................................................. .................................................. .............. 9 4.5.3 Biorad .............................................. .................................................. .................................................. ............. 9 4.6伪线扫描.............................................. .................................................. ...................................... 9 5颗粒分析............................................... .................................................. .......................... 10 5.1自动颗粒计数.............................................. .................................................. .................. 10 5.1.1阈值分割............................................. .................................................. ................................... 10 5.1.2分水岭分割............................................. .................................................. ................................. 11 5.1.3分析颗粒............................................. .................................................. ............................................. 11 5.1.4粒子跟踪............................................. .................................................. ............................................... 11 5.2手动计数............................................... .................................................. .................................. 12 5.2.1细胞计数............................................. .................................................. .................................................. ... 12 5.2.2点选择器............................................. .................................................. .................................................. .... 12 六色分析............................................... .................................................. ........................... 13 6.1荧光Colocalisation分析.............................................. .................................................. 。 13 6.1.1 Colocalisation系数............................................. .................................................. ................................ 13 6.1.2突出colocalised像素............................................ .................................................. ........................... 14 7影像强度处理.............................................. .................................................. ......... 15 7.1亮度和对比度.............................................. .................................................. ....................... 15 7.2非线性对比度拉伸............................................ .................................................. ..................... 15 7.3伽玛................................................ .................................................. ................................................. 16 7.4过滤................................................ .................................................. ................................................ 17 7.5背景校正............................................... .................................................. ........................ 18 7.6平场校正............................................. .................................................. ................................ 19 7.6.1适当的修正............................................. .................................................. ............................................. 19 7.6.2伪校正............................................ .................................................. ............................................. 19 7.7屏蔽不想要的区域.............................................. .................................................. ................... 20 7.7.1简单的掩蔽............................................. .................................................. ............................................... 20 7.7.2复杂掩蔽............................................. .................................................. ............................................ 20 二 8彩色图像处理.............................................. .................................................. ............ 21 8.1合并多通道图像............................................ .................................................. ................ 21 8.1.1蔡司LSM的多通道实验......................................... .................................................. ................... 21 8.1.2 Biorad多通道实验.......................................... .................................................. ........................ 21 8.1.3交错多通道实验.......................................... .................................................. ................. 21 8.1.4彩色合并............................................. .................................................. ................................................ 22 8.2 Pseudocolour ................................................ .................................................. ...................................... 22 9堆栈切片操作............................................. .................................................. ............ 24 9.1切片洗牌/删除/添加........................................... .................................................. ............. 24 9.2堆栈尺寸操作.............................................. .................................................. ........... 25 10 Z轴功能.............................................. .................................................. .................................. 26 10.1栈预测.............................................. .................................................. .................................. 26 10.1.1最大密度的Z -投影:......................................... .................................................. ........................... 26 10.1.2索贝尔滤波器的聚焦........................................... .................................................. ............................... 26 10.1.3小波变换的集中.......................................... .................................................. ..................... 26 10.2体积呈现............................................... .................................................. ...................................... 27 10.3表面渲染............................................... .................................................. ..................................... 27 10.4轴向切片.............................................. .................................................. ..................................... 28 10.5正交视图............................................... .................................................. ................................. 28 10.6对立体声和Anaglyphs ............................................. .................................................. ................... 29 10.6.1批量渲染,anaglyphs ........................................... .................................................. ............................... 29 10.6.2表面呈现,anaglyphs ........................................... .................................................. ............................... 30 11吨-函数.............................................. .................................................. ....................... ............ 31 11.1校正漂白.............................................. .................................................. ....................... 31 11.2 F ÷ F0的.............................................. .................................................. .................................................. ...... 32 11.3Δ- F .............................................. .................................................. .................................................. .. 33 11.4曲面绘图............................................... .................................................. .................................... 34 11.4.1“分析/曲面图”设置........................................ .................................................. .............................. 34 11.4.2 SurfaceJ设置............................................. .................................................. ............................................. 34 注释影像............................................... 12 .................................................. ...................... 35 12.1比例尺............................................... .................................................. ............................................... 35 12.1.1校准.............................................空间.................................................. ............................................. 35 12.1.2新增规模吧........................................... .................................................. ................................................ 35 12.2文本和线条.............................................. .................................................. ........................................ 36 12.2.1与添加文字问题........................................... .................................................. ....................................... 36 12.2.2添加文字/线/盒......................................... .................................................. ........................................... 36 12.2.3添加时间戳............................................. .................................................. .......................................... 37 12.2.4添加事件标记电影.......................................... .................................................. .............................. 37 13附录1:插件作者............................................ .................................................. .......... 38 14附录二:引用ImageJ和插件.......................................... ........................................... 40 14.1 ImageJ ................................................ .................................................. .................................................. 40 14.2 VolumeJ ................................................ .................................................. ............................................... 40 14.3 TransformJ ................................................ .................................................. ........................................... 40 14.4扩展的焦点............................................... .................................................. .................................... 40 15附录三:我Plugins菜单和子菜单....................................... ...................................... 41 16附录四:切出键盘工具栏.......................................... ............................................ 42 1安装IMAGEJ 1.1视窗 如果您已经有ImageJ安装,它可能是值得的卸载它(重命名的文件夹),之后 安装说明如下。这将符合您的ImageJ复制本手册。额外的插件可以很容易地 以后补上。 1.1.1安装程序文件 1。请从赖特细胞成像设备的网站WCIF_Imagej_setup.exe文件 (http://www.uhnresearch.ca/wcif)。按照下载链接。 2。运行该程序。 3。快捷方式将被安装在您的桌面和开始菜单。 1.1.2更新核心方案 现在升级ImageJ核心方案(文件IJ.JAR)从ImageJ网站立即(见第1.5.1 下文) - 由于升级的频率,在设置版本将过时。获得在该做的习惯 这个常规。 1.1.3设置内存分配 不像其他的Windows应用程序ImageJ将只使用分配给它的内存。默认情况下,WCIF ImageJ 假设安装有512 MB RAM的PC,因此ImageJ默认情况下,已拨出380兆(推荐 75%的总512MB以上)。 如果您的电脑不具备512MB内存,然后通过改变分配的内存等于RAM总量的75% 菜单命令:“编辑/选项/存储”。虚拟内存中指定超过75%是真实的RAM结果 使用造成ImageJ变得非常缓慢和不稳定。见http://rsb.info.nih.gov/ij/docs/install/。 Mac和Linux 1.2 该WCIF ImageJ安装的Windows。 Mac和Linux用户可以从下载ImageJ http://rsb.info.nih.gov/ij/download.html然后安装WCIF“插件只”包。这将安装 本手册详细的插件和“首选项文件”(IJ_PREFS.TXT),这将匹配的菜单位置 该插件和本手册的捷径。 1.3 OS2的 ImageJ将运行在OS2的,但对于Biorad运行OS2的用户,安装复杂ImageJ 8.3 文件名由LaserSharp软件所需的限制。与此帮助联系我(电子邮件tonyc)。 1.4 QuickTime的功能 当QuickTime是使用其默认设置安装,没有安装Java功能与它;这使得 ImageJ的QuickTime的功能不起作用。需要安装QuickTime的一个自定义安装,就 对于QuickTime的Java选项选中。这个选项默认是选中,并以某种方式下 安装选项列表,以便保持滚动,直到你找到它。这需要您登录与“行政中 特权“。见http://rsb.info.nih.gov/ij/plugins/qt-install.html。 1.5升级 1.5.1 ImageJ核心方案 你并不需要登录以管理员要做到这一点了,但ImageJ必须关闭。 ImageJ升级 几天之内解决,以便ImageJ本身非常频繁,主要错误应该经常进行升级。你可以 检查或注意到的版本出现在下方的工具栏启动,或找到您的版本的ImageJ 在该ImageJ财产清单底部的版本,可以通过菜单命令调用 “插件/公用事业/ ImageJ属性...”。作者:ImageJ的最新版本可以在: http://rsb.info.nih.gov/ij/upgrade/。 2 该文件需要的是所谓的IJ.JAR。新IJ.JAR下载到“C:\ ImageJ”目录和过度写 现有IJ.JAR。目前正在升级几乎每周发布的基础。详细的升级功能 可在网页上的ImageJ网站新闻页面的链接。 1.5.2插件 在ImageJ /新闻网页也有关于新的插件的细节。这些*. class文件必须下载到 的“C:\ ImageJ \插件”。 ImageJ将加载插件文件夹中的所有的插件启动。插件保存到 插件后ImageJ文件夹将无法使用,直到ImageJ已重新启动。其他插件可以找到 在ImageJ /插件网页。 1.6 Java运行环境 1.6.1关于 ImageJ运行在一个“Java虚拟机”,这是对“Java运行时环境”(JRE)的Sun公司的一部分。因此, 只要计算机有正确的JRE,ImageJ将工作,作业系统(Mac,赢得独立, OS2的,Linux操作系统,SGI公司等)。 最新的JRE和老版本可以通过以下的ImageJ /链接网页上的链接。 每隔一段时间,请检查如果Windows在Sun的JRE已经升级。有时,升级是值得的; 有时事实并非如此。软件开发工具包(SDK)也可从Sun的JRE一起具有JRE作为 一个组件,以及其他发展资源。 1.6.2 JRE的版本比较 在ImageJ的Windows从ImageJ网站安装包含JRE1.3;从WCIF网站ImageJ Beta 1中有JRE1.5。 1。 JRE1.3是最稳定的JRE的最新的,与ImageJ Windows安装分布于 ImageJ网站。 2。 JRE1.4.0允许该系统的剪贴板复制和使用插件和其他应用程序之间粘贴ImageJ (PowerPoint中,CorelDRAW中等等)。 3。 JRE1.4.2介绍了错误,造成了ImageJ崩溃时作了测量。 4。 JRE1.5 Beta 1中具有较大的窗口窗格“打开文件”使得更容易找到你的图片对话框。 (您 在这一点上可能会看到在Win98下对话框的字体奇怪的效果。) 朗读 显示对应的拉丁字符的拼音 字典 - 查看字典详细内容 1.6.3安装的JRE 1。登录为WinXP/NT/2000管理员。 2。卸载任何现有版本的Java运行时 (开始/设置/控制面板/添加,删除程序或 像这样的东西)。 3。运行新的安装文件。 4。选择自定义安装。 5。当提示输入安装目录,单击更改 按钮,并更改为 ç:\ IMAGEJ\ JRE的 6。然后确定所有对话框。 安装JRE的,而不是意味着javaw.exe SDK将不会在预期的位置。你需要移动 JRE的文件夹的内容由JDK安装到C:\ IMAGEJ\的JRE。 1.6.4编译ImageJ一个新的JRE插件 从Sun的JRE不包括所需的tools.jar文件 菜单命令“插件/编译和运行“工作。 如果没有这个文件,你会收到错误信息的权利。 朗读 显示对应的拉丁字符的拼音 Ānzhuāng JRE de, ér bùshì yìwèi zhe javaw.Exe SDK jiāng bù huì zài yùqí de wèizhì. Nǐ xūyào yídòng JRE de wénjiàn jiā de nèiróng yóu JDK ānzhuāng dào C:\ IMAGEJ\de JRE. 1.6.4 Biānyì ImageJ yīgè xīn de JRE chājiàn Cóng Sun de JRE bù bāokuò suǒ xū de tools.Jar wénjiàn Càidān mìnglìng “chājiàn/biānyì hé yùnxíng” gōngzuò. Rúguǒ méiyǒu zhège wénjiàn, nǐ huì shōu dào cuòwù xìnxī de quánlì. 字典 - 查看字典详细内容 Google 翻译适合以下用途:搜索手机聊天商务 关于 Google 翻译关闭即时翻译隐私权政策帮助 将英语译成中文(简体) 该WCIF安装可以用来编译插件。如果您升级的JRE编制所需的文件 插件可能还需要升级。当您尝试编译插件与旧版本的tools.jar中收到 中的一个“错误“的日志沿着这样的错误信息: “注意:sun.tools.javac.Main已被否决。 错误:无效的类别在C文件格式:\ ImageJ\ jre的\库\ rt.jar中(爪哇/郎/ Object.class)。该major.minor版本'49.0' 对于此工具来了解最近的事。“ tools.jar文件分布在太阳的SDK,而不是JRE。 1。下载并安装SDK。请注意目标文件夹位置。 2。删除或重命名图片/ jre的。 3。找到的JRE分在SDK文件夹。 4。将它复制到ImageJ文件夹。 5。复制的SDK/ lib中/ tools.jar中以ImageJ/ JRE的/ lib / ext目录。 2导入图像文件 ImageJ主要使用的图像文件格式的TIFF。菜单命令“文件/保存“将保存为TIFF格式。 菜单命令“文件/打开“将打开TIFF文件并导入其他常见的文件格式(例如数 支持JPEG,GIF,BMP和铂族金属,PNG等)。这些原生支持文件也可以打开拖和丢弃的文件 到ImageJ工具栏。 以上几种文件格式都可以通过ImageJ进口插件(如Biorad,诺伦,蔡司,莱卡)。当你 随后这些文件保存在ImageJ他们将不再在其原始格式。记住这一点;确保 你不要覆盖原始数据。 还有,例如PNG,PSD的(Photoshop)中,ICO等(Windows图标),进一步的PICT文件格式,可 进口通过菜单命令“文件/导入/吉米读者...“。 蔡司LSM的文件2.1导入 蔡司收购的文件共焦是可以打开直接与“处理额外( 文件类型“插件安装)通过“文件/打开“菜单命令,或由它们下降 在ImageJ工具栏。他们还可以通过进口的“蔡司LSM的导入面板“,这是 激活菜单命令“文件/导入/蔡司LSM的进口面板...“。这个插件 因为,作为一个能够获得额外的图像信息与LSM的文件中存储的优势,但 它是一个额外的鼠标点击。 图像被开辟为8位彩色图像的“无调色板”pseudocolour(!)从 LSM的采集软件。每个通道导入为一个单独的图像/堆栈。拉姆达 因此,导入为堆叠多张图片,而不是一个单一的堆栈。它们可以被转换 到堆栈使用菜单命令:“图像/垛/隐藏图像堆栈”。 一旦打开,该文件的信息可以访问和z /吨/波长的信息可以不可逆转跺脚 在图像或导出到一个文本文件。 SGI的文件2.2导入诺伦 诺伦电影可以打开在以下几个方面: “文件/导入/诺伦电影...”打开图像堆栈作为整部影片。 “文件/导入/诺伦选择...”允许你指定范围内的帧被作为栈开幕。 SGI公司的诺伦不捆绑插件的ImageJ包。要接收他们,请联系 tonyc@uhnresearch.ca或他们的作者,格雷格乔斯,这样他就可以保留用户的资料。格雷格乔斯gjoss@bio.mq.edu.au 在生物系,麦考瑞大学,悉尼,澳大利亚。 2.3 PIC文件导入Biorad Biorad PIC文件可以直接导入现在通过菜单命令“文件/打开”。只是一第一帧 Biorad堆栈可以通过打开“文件/导入/ Biorad第一帧...”。实验信息,校准和 其他有用的信息可通过图像/显示信息。 Biorad PIC文件也可以打开拖放anddropping 到ImageJ的工具栏文件。 PIC的文件被打开具有相同的查表与它的数据保存在 原始采集软件。 2.4从文件夹中导入多个文件 实验的每一个时间点购买了软件,如珀金埃尔默的UltraVIEW或接穗图像的 宏是保存时间的推移,作为一个单一的TIF文件采集软件。实验序列可 进口ImageJ通过菜单命令“文件/导入/图像序列...”。 找到目录,序列中的第一个形象,所有对话框,然后单击OK。 (你可能会得到一个错误的夫妇 信息,同时试图打开ImageJ在实验目录中的任何非图片文件。)堆栈将 “交错”您录制多个通道,并可以取消通过“交错插件/栈 - 改组/解交织“。 5 选定的图像是不一样的大小可以导入为Windows个人图像使用 “文件/导入/选择要打开的文件...”,或者是一个堆栈的“文件/导入/选择栈...文件”。不像 “文件/导入/图像序列...”功能,图像不必是相同的尺寸。如果内存是有限的, 栈可以打开为虚拟堆叠的堆叠与大多数磁盘上的剩余,直到它是必需 “文件/导入/基于磁盘的堆栈”。 2.5导入多从文件夹中的原始序列 要形成图像,ImageJ需要知道图像尺寸,位深度,每个文件和任何片编号 在文件格式无关的信息(偏移和头的大小)。您真正需要告诉它是形象 在x和y维度这些值应该从该图像被购买的软件索取。 有了这些信息按照下列步骤: 1。文件/导入/原材料... 2。选择实验的目录。 3。该对话框的典型值如下: 图像类型= 16位无符号(或8位典型值) 宽度和高度先前所确定的 偏移量= 0,图像= 1,缺口数= 0,'白'是0 =关闭 '小尾数字节顺序'=上,'打开所有文件夹'=上打开文件夹中的所有文件。 非图像文件也将被打开,可能会显示为空白的图像,需要删除:“图像/垛/删除 切片“。堆栈将“交错”您录制多个通道,并可以去交错通过 “插件/栈改组/解交织”。 2.6导入AVI和MOV文件 其中有两个插件可以打开未压缩的AVI和MOV的某些类型的文件。 开放(字)的QuickTime你需要一个自定义安装的QuickTime,包括用于Java的QT(见 1.3节)。 QuickTime影片,然后通过打开“文件/导入/ QuickTime的...”。 未压缩的AVI可以通过打开“文件/导入/的AVI ...”。 2.7其他进口功能 徕卡的sp -徕卡用户,请与我联系,如果你们能够提供一个Z系列和T系列测试ImageJ SP的文件。 奥林巴斯Fluoview - 从http://rsb.info.nih.gov/ij/plugins/ucsd.html可用。当前不捆绑 下载。 GIF动画 - 这个插件打开一个GIF动画文件为RGB堆栈。还打开一个GIF图像。 IPLab ...。允许Windows IPLab文件被打开,直接与“文件/打开”菜单命令,或拖anddrop 3保存和导出文件 “文件/保存”(热键:秒)菜单命令将保存为TIF文件的图像。其他 格式可供选择(参见右侧菜单的图像),并且可以访问 “文件/另存为...".当“保存”或“另存为”对话框打开,ImageJ将进入 在图像窗口的名字,再加上相应的文件后缀为“文件名”。 ImageJ将不添加后缀回来,如果你删除,而改变文件名称。这 使您的文件可能无法从其他程序,这需要后缀 识别的文件格式。 你可以从图像中的这个窗口的名称 - 它应该显示一个后缀后 它已被保存。如果你删除了文件后缀,然后重新保存该文件中 它通常恢复所需的格式。 GIF动画...这个插件保存堆栈作为一个动画GIF。它可以在RGB或8 位的图像。 PNG格式,图像,XBM,热重时,Photoshop(PSD)的,交叉相位调制或PCX可以保存 “文件/另存为/吉米作家...”。运行该插件,然后选择所需的格式,从 下拉框。 未压缩的AVI文件是出口或者通过“文件/另存为... /的AVI ...”,打开 通过“文件/另存为/的AVI ..”。该框架导出的AVI影片率确定 “图像/垛/动画选项...”设置,可在0.1到100 每秒帧数(fps)。 ImageJ的AVI格式保存为“压缩”。未压缩的文件比较大, 而应在任何PC / Mac的解码器可播放没有任何问题。有免费 将现有的AVI类型之间的转换(如视频工具RAD数据通信公司),但一旦压缩,ImageJ不会 再不能将它们导入(除非你使用的RAD工具来重新保存为视频压缩的AVI它们)。 出口的QuickTime MOV文件是通过菜单命令“文件/另存为/ QuickTime导出”和通过开 菜单命令“文件/导入/ QuickTime的...”。 该框架的最终QuickTime影片的税率是载在弹出的对话框中命名后,你你*. MOV文件。 压缩设置也设置在这里。尽管AVI文件相比,这个更大的灵活性,安飞士往往是 更多MSWindows友好,不需要自定义安装的QuickTime(见1.4节)。 Flash MX的将进口未压缩的AVI文件。帧速率将取决于闪光,没有的AVI 电影文件。 4强度与时间分析 4.1亮度和对比度 为了提高图像的可视化,显示的亮度和对比度可以 调整后的“图像/调整/亮度对比度”(热键:SHIFT键+ C)。 “自动”适用于一个以何种方式显示图像的智能对比度拉伸。 亮度和对比度进行调整的基础上分析图像的(或选择的) 直方图。如果按多次,它允许一个像素的比例逐步增加 趋于饱和。 复位改变了“最大化”和“最小”回到0和255 8位图像和背面 到最高和16位图像的图像的直方图最小。 如果汽车不产生理想的结果,选择一个单元格的背景再加上一些地区 一个区域的利益率(ROI)工具,然后点击“自动”按钮。然后它会做一个伸展 在投资回报率的基础上的强度。 按应用按钮永久改变图像的实际灰度值。 不要在分析过程中按这个按钮图像强度! 如果你喜欢的图像将显示为“黑白色”,而不是“黑底白字”外, 图像显示,可“倒”的命令“图像/颜色表/反转- LUT的”。该命令 “编辑/反转...”倒转的像素值不只是图像显示方式。 从单一的投资回报率4.2入门强度值 如果影片已被列为开放栈,投资回报率可以选择用命令分析:“插件/强度 与时间的关系图“(热键:”1“)。这将生成一个数字单柱 - 每行片的强度。 前4列行的投资回报率的细节。这有利于确保投资回报率是不相同的两次分析 并允许任何有趣的投资回报搬迁。的细节组成的X坐标,Y坐标,宽度和 高度的投资回报率。如果投资回报率是一个折线/写意的投资回报率,而不是方形/椭圆形,详情载,犹如 投资回报率是一个椭圆形/平方米。该(椭圆形)投资回报率可以通过输入详细信息提示恢复的“Plugins /还原 投资回报率“的命令。 结果显示在一个情节与情节的窗口标题中的投资回报率详细信息窗口。该地块包含 按钮列表,保存,复制。复制按钮复制到剪贴板上的数据在那里可以粘贴到等待 Excel工作表。副本的按钮的设置下可以找到“编辑/选项/图配置文件选项”。 推荐的设置是:不要保存x值(阻止片编号数据被粘贴到Excel)和 Autoclose(阻止您不必关闭每次分析阴谋。 4.3强度随时间的动态分析 插件“插件/栈 - ž&T公司的预测/动态ZProfile”将以更新的绘图窗口每一次的投资回报率 选择是感动。这可能有助于找到例如钙信号的起始位点。 4.4如何从多个投资回报强度值 可分析多个投资回报一次使用乙Dougherty的“多办法”插件。有一个本地的“投资回报率 经理“的功能,做了除产生的不排序的列的结果类似的工作。检查 Bob的网站更新:http://www.optinav.com/ImageJplugins/list.htm 多措施插件自带的安装是V2。 1。打开T系列。 2。这是一个值得参考栈产生的投资回报来补充。使用 “图像/垛/ Z型项目”功能(热键:SHIFT键+ Z)的§。选择“平均”选项。 3。重命名这个图片“号expt名称”或类似令人难忘。 4。打开“多招”插件(“插件/投资回报率/多办法”)。 5。选择背景的投资回报率,首先,并与多测量对话框按钮列表 “新增+抽奖”(热键:输入又名回车)。继续添加单元格 投资回报。 6。一旦完成选择投资回报将在参考图像进行分析,保存 参考图像实验的数据文件夹,然后选择要堆栈 分析。 7。单击多测量对话“多”(不是“办法”)按钮来衡量一切 投资回报。点击“是”对“进程堆栈?”对话框。 8。进入“结果”窗口。选择菜单项“编辑/全选...”。那么,“编辑/复制全部”。 9。前往Excel和粘贴数据。随着大型数据集这可能需要一些时间,让你检查新数据粘贴 而不是过去的数据集抄多措施。 10。要复制的投资回报率统筹到Excel电子表格,确保有一个空 行以上的强度数据。测量了在多对话框,点击“复制清单” 按钮。 11。到Excel中,选择上方的第一个数据列的空白单元格,然后粘贴 投资回报率坐标。 该投资回报可以存储并重新打开后使用多措施对话框按钮 “保存”。实验数据保存在文件夹中。该投资回报后可以打开 无论是个人(多测量对话框按钮“打开”)或一次全部(多 测量对话框按钮“打开所有”),这将打开一个文件夹中所有的投资回报。 椭圆形和长方形的投资回报,也可以从恢复的x,y,L时,h值单独使用 “插件/投资回报率/ SpecifyROI ...”(热键:Shift + G键)。 朗读 显示对应的拉丁字符的拼音 字典 - 查看字典详细内容 朗读 显示对应的拉丁字符的拼音 字典 - 查看字典详细内容 朗读 显示对应的拉丁字符的拼音 字典 - 查看字典详细内容 朗读 显示对应的拉丁字符的拼音 字典 - 查看字典详细内容 ©2010商务工具译者工具包关于 Google 翻译博客隐私权政策帮助 § ImageJ假设栈是Z系列,而不是因此与第三维的许多功能的T系列 图像堆栈被称为“Z型“的东西- 如“Z轴专页“是随着时间的推移情节强度。 4.5获取时间戳数据 4.5.1蔡司LSM的 一旦通过蔡司LSM的面板进口,timestamp数据可以提取该小组的'应用T型邮票' 按钮。这将询问您是否要添加时间戳到图像,或在一个文本文件显示 储蓄/粘贴到Excel等 4.5.2诺伦 在大多数情况下的X -轴的数据,即每帧的时间,可以计算出从采集速率和帧 编号(如301帧的采集速率收购设置为1帧,每0.5秒25获得 分钟)。然而,采集速率为非线性的301架以上的实验,实际上是收购 25分钟12秒。每个帧存储与它的“时间戳”,确切的时间(以纳秒!),这是 收购。这些信息可以提炼出一个开放的电影。 这部电影必须打开一个堆栈和时间戳可以用命令提取:“导入/诺伦 时间戳(毫秒)“,而诺伦电影是开放和选择。 timestamp数据显示在“结果” 窗口。要复制数据,在Windows点击鼠标右键,选择“选择全部”,然后右击 再次,选择复制。 timestamp数据(由电影名陪同)可以被粘贴到Excel中。 SGI公司的诺伦不捆绑插件的ImageJ包。要接收他们,请联系 tonyc@uhnresearch.ca或他们的作者,格雷格乔斯,生物,麦格理系 大学,悉尼,澳大利亚。 4.5.3 Biorad 这可通过菜单命令“图像/显示信息...”。向下滚动并应给予时间 每个切片被收购。这可以被选中,复制到Excel中的时间和数量得到 搜索和替换(Excel菜单命令“编辑/替换”)的文字,只留下时间数据。该 “过去”的时间可以计算减去所有后续行的行1。 4.6伪线扫描 “Linescanning”是一种常见的方式取得许多共焦显微镜在一个像素宽行 所收购的时间,而不是norma1的2 - D,xy形象的时期。通常,这可以更快的收购。该 在单像素宽的图像时间的推移,从左至右堆放产生的2 - D图像(我,电子和XT)。 “伪线扫描”是从一个3 - D线扫描型XT的阴谋(的x,y,t)的timecourse产生和可能是有用的 在显示2维3 - D数据(的x,y,t)的。 行的利益,必须制定其次是命令: “图像/垛/ Reslice”或键盘“/”。它会提示行宽。 输入线宽您希望得到的平均值。伪线扫描“栈” 会产生,每片代表伪的singlepixel线扫描 宽线沿利益一致。对于一般的伪线扫描 “栈”,选择“图像/垛/ Z型项目...”并选择平均 命令。可用于折线虽然这将只允许一个单一的 像素切片作。 这个例子说明上述事件的基本钙钙 波。 HeLa细胞装入钙敏感的荧光,荧光- 3和 同时响应成像组胺的应用。答:框架取自时间进程在高峰 钙释放的反应。 (二)采取了沿XY像素线,并排堆叠方由右至左 生成一个“伪线扫描”。这样可以从它的起始位点波发展可视化。 朗读 显示对应的拉丁字符的拼音 字典 - 查看字典详细内容 5颗粒分析 颗粒计数,可自动完成,如果标本适合于它,即单个粒子可以触摸 - 但不是太多了!如果自动颗粒计数不能这样做,ImageJ可以方便手工计数与 “点选择器“或“细胞计数“插件。 5.1自动颗粒计数 最大的问题是一个被称为“分割“,这是区分对象从背景。 一旦对象已经成功分割,他们就可以进行分析。 朗读 显示对应的拉丁字符的拼音 5 Kēlì fēnxī Kēlì jìshù, kě zìdòng wánchéng, rúguǒ biāoběn shìhé yú tā, jí dāngè lìzǐ kěyǐ chùmō - Dàn bùshì tài duō le! Rúguǒ zìdòng kēlì jì shǔ bùnéng zhèyàng zuò,ImageJ kěyǐ fāngbiàn shǒugōng jìshù yǔ “Diǎn xuǎnzé qì” huò “xìbāo jìshù” chājiàn. 5.1 Zìdòng kēlì jìshù Zuìdà de wèntí shì yīgè bèi chēng wèi “fēngē”, zhè shì qūfēn duìxiàng cóng bèijǐng. Yīdàn duìxiàng yǐjīng chénggōng fēngē, tāmen jiù kěyǐ jìn háng fēnxī. 字典 - 查看字典详细内容 RAW Threshold 5.1.1阈值分割 自动颗粒图像分析需要的是一个“二元“的形象,即黑色或白色。该软件需要 知道确切位置的边缘进行形态学测量。 “门槛“范围设定和像素 图像的价值在于在此范围内转换为黑色;与此范围之外的像素值转换 为白色(或反之亦然什么用户请求而定)。 有几种方法可以设置阈值。对于黑白图像 它是通过你做最简单的菜单命令 “图像/调整/阈值“。当阈值被设置时, 阈值范围内的像素显示为红色。用户 然后改变然后“套用“的门槛,图像将被 转换为二进制图像 朗读 显示对应的拉丁字符的拼音 5.1.1 Yù zhí fēngē Zìdòng kēlì túxiàng fēnxī xūyào de shì yīgè “èr yuán” de xíngxiàng, jí hēisè huò báisè. Gāi ruǎnjiàn xūyào Zhīdào quèqiè wèizhì de biānyuán jìnxíng xíngtài xué cèliáng. “Ménkǎn” fànwéi shè dìng hé xiàngsù Túxiàng de jiàzhí zàiyú zài cǐ fànwéi nèi zhuǎnhuàn wèi hēisè; yǔ cǐ fànwéi zhī wài de xiàngsù zhí zhuǎnhuàn Wèi báisè (huò fǎnzhī yì rán shénme yònghù qǐngqiú ér dìng). Yǒu jǐ zhǒng fāngfǎ kěyǐ shèzhì yù zhí. Duìyú hēibái túxiàng Tā shì tōngguò nǐ zuò zuì jiǎndān de càidān mìnglìng “Túxiàng/tiáozhěng/yù zhí”. Dāng yù zhí bèi shèzhì shí, Yù zhí fànwéi nèi de xiàngsù xiǎnshì wèi hóngsè. Yònghù Ránhòu gǎibiàn ránhòu “tàoyòng” de ménkǎn, túxiàng jiāng bèi Zhuǎnhuàn wéi èrjìnzhì túxiàng 字典 - 查看字典详细内容 对于彩色图像,设置阈值是一个多一点 复杂,因为红色,绿色和蓝色通道,每个通道 需要不同的阈值范围。该插件 “插件/彩色功能/阈值颜色”可以 用来做这个最容易。这将打开一个相当 复杂和广泛的控制窗口。该 香水最简单的方法是使用颜色阈值 甄选工具之一,选择的对象之一 兴趣,然后点击“样品”在按钮 “门槛色彩”控制窗口。这应该 去除图像中的像素没有像素 作为在选择相同的颜色。该 阈值可手动调整与滚动条 在直方图窗格。它可能会更容易 构思什么你在这一点上做的 开关从默认色调的控制窗口, 饱和度和亮度彩色模型以红,绿 蓝色模型切换在选项按钮 底部的控制窗口。图像可以 作为一个二进制图像显示与“门槛” 按钮,并转换为二进制图像通过菜单命令“Image/Type/8-bit”(?!). 11 5.1.2分水岭分割 在二进制图像略有重叠的对象可能是分开使用菜单命令 “过程/二进制/分水岭”。这是很好的说明了分割过程与此图的ImageJ 文件网页(http://rsb.info.nih.gov/ij/docs/index.html)。 朗读 显示对应的拉丁字符的拼音 字典 - 查看字典详细内容 首先需要的图像转换成二进制(通过阈值设定)。黑色的像素,然后替换 灰色像素的强度成正比,他们从一个白色像素的距离(即黑色像素靠近边缘, 浅灰色的,那些接近的中间)是接近黑色。这是欧氏距离图(电火花)。从这一点 计算对象的侵蚀中心的最终点(UEPs),这即是从等距点 边缘。这些点的ERE然后扩张,直到遇到另一个黑色像素,然后绘制一个分水岭线。 5.1.3颗粒分析 一旦图像被分割,菜单命令“分析/分析颗粒” 可以用来获取各种信息颗粒大小和数量。 设置最小大小和最大大小,以排除的对象出现在二进制 图像显然不感兴趣的对象。选择“显示:纲要”选项 显示被测物体的图像。然后可以合并的最初 演示的目的。倒置轮廓图像,然后使用菜单命令 “插件/彩色功能/彩色合并”添加原始和轮廓图像。 粒子分析可以自动通过插件或一次正确的宏 阈值和粒度范围已被确定为您感兴趣的对象。 看到“插件/颗粒分析/核计数器”插件,它的源代码 定制,以你的形象。 5.1.4粒子追踪 在“MTrack2”插件(“插件/颗粒counting/MTrack2”)跟踪粒子的坐标和报告 每个时间点和总路径长度 5.2手动计数 您可以使用ImageJ工具栏十字(标记和计数)工具来计算粒子。然而,更大程度 访问控制可以用“点选取器“或”细胞计数“插件。 5.2.1细胞计数 当然后“插件/颗粒计数/细胞 计数器“插件)运行时,一个新的形象 窗口生成与原始图像 加四沿底部(红色式按键, 绿色型,蓝色和黄色型型)。 点击一个按钮的颜色变化 标识的工具。结果表将一 理货的每种类型的细胞数 标记。按一下按钮,将结果 生成的数据的汇总 5.2.2点选择器 “插件/颗粒计数/ PointPicker“。运行此插件将改变ImageJ的工具栏的PointPicker 工具栏(如下)。 十字架可逆覆盖到的图像,逐步改变颜色(这从不同的十字线 工具,它在像点不可逆的邮票)。用点拾取工具,可以移动和十字架 删除。一旦标记完成后,交叉坐标可以通过按钮来访问 这将产生“点列表“对话框,允许您显示,保存或打开点的坐标。 点击“显示“显示在结果窗口,在那里他们可以保存或复制到坐标 系统剪贴板。一旦完成,您可以通过点击返回到正规ImageJ工具栏 按钮。 6彩色分析 6.1荧光Colocalisation分析 一个关键问题,也会影响colocalisation分析是通过流血。 Colocalisation通常涉及 确定有多少绿色和红色重叠。因此,至关重要的是,绿色发光染料不 无助的红色信号(通常是红色染料不会发射绿色荧光,但是这需要 实验验证)。一种可能的方式,以避免流血通过是获得红色和绿色的图像 顺序,而不是同时(与正常双通道共聚焦成像)和狭隘的使用 带发射过滤器。单路和不知名的控制必须用于评估流血通过。 6.1.1 Colocalisation系数 6.1.1.1“图像相关附加”和“红绿相关器”插件 这两个插件实际上是相同的,除了“图像相关加”需要两个灰度图像, 选择和“红,绿相关器”插件在目前的RGB图像作品。 这些插件产生一个256 × 256散点图加关联系数。在每一个散点图,第一(通常 红色)图像组件是代表沿x轴,第二幅图像沿y轴(通常是绿色)。该 一个给定的第一个图像像素强度作为的X坐标散点图点和强度 第二幅图像中对应像素的Y坐标。 在“相关情节”影像中的每个像素的强度代表的像素的显示那些频率 特别是红/绿色的价值。因为你们大多数图像可能会背景下,出现频率最高的像素 将低强度,所以在散点图最亮的像素在左下角 - 即X〜为零, Ÿ〜为零。在“红绿相关情节”图像的强度代表了像素的实际颜色 形象。 在“插件/栈区RGB /红绿相关器”插件将RGB图像,分割它,然后生成 相关图和数据。这将工作在原始影像或整幅图像,如果没有投资回报率的投资回报率上选择。 这两个插件生成各种colocalisation系数:皮尔逊(率),重叠(R)和Colocalisation供应量(M1, 货币供应M2)看曼德斯,能源及排放,维贝克,FJ与阿登,司法机构政务长'测量的合作对象定位在双色 共聚焦图像',j的显微镜,169,375-382,(1993年)。有关详细信息,请参阅教程片'Colocalisation'。 6.1.2突出colocalised像素 6.1.2.1“共存”插件 插件/彩色功能/共存。这个插件将产生一个colocalised像素的图像,也是 对这些图像叠加像素的RGB colocalised合并两个8位的图像。这种类型的colocalisation 要求用户决定一个“门槛” 值,可以引入偏差。 这个插件突出colocalised 分两个8位的图像(或堆叠)。 该colocalised会出现白色点 默认情况下(显示值= 255)。该 插件融合了红色和绿色的8位 以一个RGB图像通道,并强调 在白色的colocalised像素。像素 如果他们认为colocalised强度 比其更高的门槛 通道(默认设置为50):而且如果 它们的强度比高于高 比设定值(默认情况下在50%设置)。 一个只有白色的第二幅图像 colocalised像素,如果产生 “同时显示colocalised像素单” 选项被选中。 6.1.2.2“共存取景器“插件 菜单命令“插件/栈 -函数的RGB/共存探测器“ 这个插件会提示你两个灰阶 图像并创建一个散点图和 红色绿色合并图像。像素 所代表的散点图点可 通过选择加以强调点与 矩形选择工具而已。该 32位散点图是最好的可视化后 有过它的对比度拉伸 ( “图像/调整/亮度及对比度...“)。 朗读 7图像强度处理 7.1亮度和对比度 亮度和对比度窗口(热键:SHIFT键+ C;菜单命令 “图像/调整/亮度和对比度...”)将允许你改变形象的方式 显示。的x轴表示的情节,在图像的像素强度,Y轴 代表,他们的显示方式(Y轴的底部是显示黑色强度;顶部 白色显示)。起初,有一个形象的强度之间的线性关系 显示亮度。提高最低值来显示图像的背景为黑色 (IE)的零,降低最大值显示在图片的最亮的物体 白色。这是一个最好的实现灰度图像载入了“高住低训对照表” (“插件/查表/高低的指标...”;热键:F1)的。 自动按钮适用于线性直方图拉伸(又名正常化),即它设置 显示值以匹配图像的最大和最小强度。点击 自动按钮将使越来越多的饱和量。通过点击应用按钮 影像中的值被改变,以符合他们显示的值。不这样做之前, 量化强度值!如果你正在处理一个栈,你将有选择 这一调整适用于整个堆栈。 如果自动不会产生理想的结果,选择一个单元格加上一些地区的投资回报率工具的背景, 然后点击自动按钮。然后它会做的强度范围内的投资回报率的基础上延伸。 如果你喜欢的动画显示为“白,黑”而不是“黑与白”,形象展示 可以“倒”的命令“图像/颜色表/反转- LUT的”。命令“编辑/反...”反转 像素值不只是图像的方式显示出来。 朗读 显示对应的拉丁字符的拼音 字典 - 查看字典详细内容 7.2非线性对比度拉伸 更多的亮度和对比度调节控制,可实现与 “过程/增强对比度“菜单命令。在这里,当应用到一个栈,它适用于 每个切片的直方图的调整,不仅是当前显示为一体,是 完成了窗口的亮度和对比度。 “均等化“应用了基于直方图的平方根非线性拉伸 强度(参见联机指南图像处理: http://www.dai.ed.ac.uk/HIPR2/histeq.htm)。 在“正常化“选项执行在图像上以类似的方式简单的线性延伸到“自动“的选项 亮度和对比度的窗口,除了当应用到堆栈中的每个堆栈片不同的是调整 根据切片的直方图。 16 7.3伽玛 虽然这可以作为一种非线性直方图调整。微弱的天体可以更激烈无 饱和(伽玛“1)明亮的物体。同样,中等强度的对象可以是在没有调暗 在(伽玛“1)明亮的物体。每个像素的亮度是“提出的权力“的伽玛值,然后 扩展到8位或分和16位图像最大。 对于8位图像,新的强度=255× [(旧强度÷255)伽玛] 可以通过伽玛调整“过程/数学/伽玛“命令或“插件/公用事业/伽玛滚动条“ 插件。后者将打开一个新窗口的图像复制并可以调整与滚动的伽玛 酒吧。点击“完成“当你完成。这是一个有点古怪,不反应良好,如果你改变图像 中期调整!这并不能在协议栈。您可以使用滚动条来确定所需的伽玛值 您的一个切片栈,然后再应用这种伽玛值到堆栈通过“过程/数学/伽玛“命令。 朗读 显示对应的拉丁字符的拼音 16 7.3 Jiā mǎ Suīrán zhè kěyǐ zuòwéi yī zhǒng fēi xiàn xìng zhífāng tú tiáozhěng. Wéiruò de tiāntǐ kěyǐ gèng jīliè wú Bǎohé (jiā mǎ “1) míngliàng de wùtǐ. Tóngyàng, zhōngděng qiángdù de duìxiàng kěyǐ shì zài méiyǒu diào àn Zài (jiā mǎ “1) míngliàng de wùtǐ. Měi gè xiàngsù de liàngdù shì “tíchū de quánlì” de jiā mǎ zhí, ránhòu Kuòzhǎn dào 8 wèi huò fēn hé 16 wèi túxiàng zuìdà. Duìyú 8 wèi túxiàng, xīn de qiángdù = 255 × [(jiù qiángdù ÷ 255) jiā mǎ] Kěyǐ tōngguò jiā mǎ tiáozhěng “guòchéng/shùxué/jiā mǎ” mìnglìng huò “chājiàn/gōngyòng shìyè/jiā mǎ gǔndòng tiáo” Chājiàn. Hòu zhě jiāng dǎkāi yīgè xīn chuāngkǒu de túxiàng fùzhì bìng kěyǐ tiáozhěng yǔ gǔndòng de jiā mǎ Jiǔbā. Diǎnjī “wánchéng” dāng nǐ wánchéng. Zhè shì yīgè yǒudiǎn gǔguài, bù fǎnyìng liánghǎo, rúguǒ nǐ gǎibiàn túxiàng Zhōngqí tiáozhěng! Zhè bìng bùnéng zài xiéyì zhàn. Nín kěyǐ shǐyòng gǔndòng tiáo lái quèdìng suǒ xū de jiā mǎ zhí Nín de yīgè qiēpiàn zhàn, ránhòu zài yìngyòng zhè zhǒng jiā mǎ zhí dào duīzhàn tōngguò “guòchéng/shùxué/jiā mǎ” mìnglìng. 字典 - 查看字典详细内容

下载文档到电脑,查找使用更方便

文档的实际排版效果,会与网站的显示效果略有不同!!

需要 10 金币 [ 分享文档获得金币 ] 13 人已下载

下载文档